Results 1 to 7 of 7

Thread: rF2 Problem

  1. #1
    Join Date
    May 2014
    Location
    Vancouver, WA USA
    Posts
    2,526

    Default rF2 Problem

    Since yesterday I have this issue: rF2 Launcher loads ok > Game loads ok > Track loads and initial menu appears, but then while it's on that initial menu screen (assuming cars are loading at this point) game completely disappears!?. I can see on Steam menu page that it is showed as "rFactor 2-Running". If I have the Task Manager opened simultaneously, I can see rFactor.exe disappears from the list of open apps! But "Steam Client Bootstrapper" is running with 1.4 GB memory. When I expand it (open drop-down menu) I see there that rFactor is still alive with 1.2 GB memory usage. But there is no display!

    Just now I removed a lot of unused tracks & mods plus duplicate folders of all the Studio cars (within their own folders). Did an integrity ck for the 5th time now and it installed some of the DLC car updates. Re-tried it and I still have the same problem.
    Also when I close the rFactor.exe in task manager Steam still shows it as running. To be able to restart rF2 I have to close and restart Steam, otherwise it is stuck in this state.
    __The view is great from moral high ground__

  2. #2
    Join Date
    Nov 2016
    Location
    Soutwest Virginia, USA
    Posts
    2,294

    Default

    Quote Originally Posted by Jon Uyan View Post
    Since yesterday I have this issue: rF2 Launcher loads ok > Game loads ok > Track loads and initial menu appears, but then while it's on that initial menu screen (assuming cars are loading at this point) game completely disappears!?. I can see on Steam menu page that it is showed as "rFactor 2-Running". If I have the Task Manager opened simultaneously, I can see rFactor.exe disappears from the list of open apps! But "Steam Client Bootstrapper" is running with 1.4 GB memory. When I expand it (open drop-down menu) I see there that rFactor is still alive with 1.2 GB memory usage. But there is no display!

    Just now I removed a lot of unused tracks & mods plus duplicate folders of all the Studio cars (within their own folders). Did an integrity ck for the 5th time now and it installed some of the DLC car updates. Re-tried it and I still have the same problem.
    Also when I close the rFactor.exe in task manager Steam still shows it as running. To be able to restart rF2 I have to close and restart Steam, otherwise it is stuck in this state.
    Did you try deleting d3d9.dll? (if you have it)....not sure this is tied to your issue.
    Check this thread at S397 forum for details on that, if you haven't put eyes on it.

  3. #3
    Join Date
    May 2014
    Location
    Vancouver, WA USA
    Posts
    2,526

    Default

    Quote Originally Posted by Jason Whited View Post
    Did you try deleting d3d9.dll? (if you have it)....not sure this is tied to your issue.
    Check this thread at S397 forum for details on that, if you haven't put eyes on it.
    Yeah I remember that recent thread, I'll ck. d3d9.dll, it was a file that came (installed) with one of the plug-ins if I remember correctly.
    EDIT: d3d9dll file was part of TrackMap plug in installation process. Had to be dropped manually into Bin32 and Bin64 folders. Uninstalling TrackMap does not remove it from those folders.
    Last edited by Jon Uyan; 12-27-2018 at 03:25 PM.
    __The view is great from moral high ground__

  4. #4
    Join Date
    May 2014
    Location
    Vancouver, WA USA
    Posts
    2,526

    Default

    Also somebody is reporting this too:
    I turned off shadows and it worked. Once I turned them back on, even on low, it CTD. With shadows enabled, I can join a track but get CTD when it loads a car. Spectator mode is fine until someone joins and a car is loaded.
    those darn shadows again!
    I'll report if I have any improvement. Thanks for the help so far.
    __The view is great from moral high ground__

  5. #5
    Join Date
    Nov 2016
    Location
    Soutwest Virginia, USA
    Posts
    2,294

    Default

    Quote Originally Posted by Jon Uyan View Post
    Yeah I remember that recent thread, I'll ck. d3d9.dll, it was a file that came (installed) with one of the plug-ins if I remember correctly.
    Old track map stuff or something.
    I didn't personally have it, so didn't suffer that particular issue.
    Hadn't seen the one on shadows causing CTD. ....that's a bit concerning, if true.

  6. #6
    Join Date
    May 2014
    Location
    Vancouver, WA USA
    Posts
    2,526

    Default

    Quote Originally Posted by Jason Whited View Post
    Old track map stuff or something.
    I didn't personally have it, so didn't suffer that particular issue.
    Hadn't seen the one on shadows causing CTD. ....that's a bit concerning, if true.
    Well, good news and a big relief, it was the d3d9dll file (I had it for some reason), and removing it from Bin64 folder fixed the issue. Thanks again for the reminder.
    Funny thing is I was on P1 server last night with Nic for about an hour without any problem, trying the new GT3 cars (go figure).

    I didn't think much of that thread at S397 about the d3d9dll because I remember I had deleted it last year when DX11 came along and it was not working with it. I wonder Z1 Dashboard or Motec i2pro
    also uses d3d9dll? No idea and if they are they will be out of commission for awhile until S397 fixes the conflict.
    Last edited by Jon Uyan; 12-27-2018 at 03:17 PM.
    __The view is great from moral high ground__

  7. #7

    Default

    d3d9dll in rF2...

    I searched my own rF2 addons folder, no d3d9dll. The only time I ever saw it in rF2 was with the DX9 clipping widget. I don't use Z1 though.

    Glad to see you figured it out.
    I own crappy boxes... well you know what? 16gigs of 1866 HyperX FURY on a Asus P7P55 LX with an i7-860 running a used GTX970 4GD5T OC on an new AOC Q2963 21:9 screen... I'm doing way better! I even got myself a barely used G29! But I still endlessly mod rFactor...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Champion Motorsports

We've been providing computer-based quality sim racing for our membership for nearly two decades.

Our various iRacing, Assetto Corsa, Automobilista, and rFactor 2 leagues are "serious fun" in a friendly atmosphere. We also host rallying special events in Richard Burns Rally and Dirt Rally.

While our events are competitive, we welcome all sim racing drivers from beginners to the seasoned professional. No matter what your level of experience we have events throughout the week to match your sim racing interests.

To get started, register for an account by clicking here.