Results 1 to 8 of 8
  1. #1
    Bill Brehm's Avatar
    Bill Brehm is offline Retired
    Join Date
    Jun 2013
    Location
    Columbus, Ohio
    Posts
    611

    Default Problems with AMS

    This is quickly becoming my most hated game, maybe even below AC. Today I can't assign my controller functions to anything but my left mouse button.

    Any suggestions, I'd really like to work.
    “Life isn't about waiting for the storm to pass...It's about learning how to dance in the rain.”

  2. #2
    Jason Whited's Avatar
    Jason Whited is online now Senior Community Leader
    Join Date
    Nov 2016
    Location
    Soutwest Virginia, USA
    Posts
    1,150

    Default

    Quote Originally Posted by Bill Brehm View Post
    This is quickly becoming my most hated game, maybe even below AC. Today I can't assign my controller functions to anything but my left mouse button.

    Any suggestions, I'd really like to work.
    What is wrong with AC? It's a fine sim as well.

    Anyways, what wheel?
    Did you check to all the usual stuff; drivers up to date or whatever ones you use? All is working with the wheel outside of AMS?

    Not sure what advice anyone can offer on such little info. But I'd start with checking the wheel, drivers, make sure it's all working outside of AMS and then go back in and try to re map or load your saved profile. (I usually just remap...because losing controller profiles and having to do that is not new to me and it's not sim specific and it's not because I don't save them. Sometimes, stuff goes funky with these sims. Don't ask me, I haven't a clue. And yes, it is annoying sometimes)

    Hope you get it working

  3. #3
    Bill Brehm's Avatar
    Bill Brehm is offline Retired
    Join Date
    Jun 2013
    Location
    Columbus, Ohio
    Posts
    611

    Default

    Everything works with other sims. With AMS when you left click on a controller function, it assigns the left mouse button to that function. Select something else, and it assigns the left button to that function. It worked fine yesterday.

    The game is great, when it works. I'll try reinstalling the controllers.
    “Life isn't about waiting for the storm to pass...It's about learning how to dance in the rain.”

  4. #4
    Gilles Lalonde's Avatar
    Gilles Lalonde is online now Established Member
    Join Date
    Dec 2016
    Location
    Montreal, Quebec
    Posts
    349

    Default

    Hey,

    While making sure that, in the bottom left, under device, it does list your wheel as Joy1?

    If yes, you click on some Input in the center box, like Shift Up, a box appear on the screen waiting for an input, then you press on one of the paddles and there is no reaction in the box?
    If yes, can you assign Shift Up to a keyboard key?

    Like the crash to desktop you had, which after a reinstall, it worked fine... that was most probably just the installation of the mod... not an AMS issue... no need to hate the game. So like that previous issue, please Bill, better too much details than not enough.
    I own crappy boxes... well you know what? 20gigs on a Asus P7P55 LX with an i7-860 running an Asus 560GTX (1gig) on an new AOC Q2963 screen... I'm doing way better! But I still endlessly mod rFactor...

  5. #5
    Bill Brehm's Avatar
    Bill Brehm is offline Retired
    Join Date
    Jun 2013
    Location
    Columbus, Ohio
    Posts
    611

    Default

    I don't really hate the game, just get so frustrated with all the oddball things that can go wrong.

    Like my now resolved controller problem. It seems that in AMS if any controller button is active when you left click on a function, that function is assigned to that button. In my case my old G27 shift selector is so worn out that the selector lever, by it's own weight, goes active if bumped just right. So when I left clicked the steering function the selector (B8) is assigned to steering. I thought 'B8' was odd for the mouse button. I jerry rigged it to neutral using my wife's pony tail band. Considering my priority list, it will still be there 10 years from now.

    I'm certain there was some trash left over in my game as I was adding and removing mods and tracks since I bought it. Reinstalling was the only way I could be sure it was clean.

    So once again all is well.
    “Life isn't about waiting for the storm to pass...It's about learning how to dance in the rain.”

  6. #6
    Jason Whited's Avatar
    Jason Whited is online now Senior Community Leader
    Join Date
    Nov 2016
    Location
    Soutwest Virginia, USA
    Posts
    1,150

    Default

    Quote Originally Posted by Bill Brehm View Post
    I don't really hate the game, just get so frustrated with all the oddball things that can go wrong.

    Like my now resolved controller problem. It seems that in AMS if any controller button is active when you left click on a function, that function is assigned to that button. In my case my old G27 shift selector is so worn out that the selector lever, by it's own weight, goes active if bumped just right. So when I left clicked the steering function the selector (B8) is assigned to steering. I thought 'B8' was odd for the mouse button. I jerry rigged it to neutral using my wife's pony tail band. Considering my priority list, it will still be there 10 years from now.

    I'm certain there was some trash left over in my game as I was adding and removing mods and tracks since I bought it. Reinstalling was the only way I could be sure it was clean.

    So once again all is well.


    Glad you got it fixed, Bill.
    Definitely always something with these sims, I hate em too sometimes and will wonder to myself why the heck I spend all this time fixing them over and over, so I sympathize.

  7. #7
    Gilles Lalonde's Avatar
    Gilles Lalonde is online now Established Member
    Join Date
    Dec 2016
    Location
    Montreal, Quebec
    Posts
    349

    Default

    Good to hear.

    If I understood right, here's the quick fix for that:


    Other vids in the list probably have a more comprehensive fix.
    I own crappy boxes... well you know what? 20gigs on a Asus P7P55 LX with an i7-860 running an Asus 560GTX (1gig) on an new AOC Q2963 screen... I'm doing way better! But I still endlessly mod rFactor...

  8. #8
    Joe Miller is online now Senior Member
    Join Date
    Nov 2016
    Location
    Gulfport MS
    Posts
    378

    Default

    The ole not in neutral trick. Happens with all sims. LOL. I've done it more than a few times

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •