Results 1 to 5 of 5

Thread: Runtime error

  1. #1
    oldnslo's Avatar
    oldnslo is offline Bob Roberson
    Join Date
    Jun 2010
    Location
    Peachtree, NC
    Posts
    223

    Default Runtime error

    What is happening ? I got kicked off the race two weeks in a row. And it happened today when I attempted to watch the replay of last night's race. I restarted Automobilista and then it worked.
    I was able to return this week but not the last race. I thought it was Windows update but that's not so. I get a message in a box that says" Microsoft Visual C ++ Runtime Library. Next line has circle with an X through it. With "Runtime Error. Below that "Program...ogram"
    Files\Steam\Steam apps\automobilista.
    "This application has requested the runtime to terminate in an unusual way. Please contact the applications support team for more information" I have no idea what the heck they are talking about. I just know I'm tired of fighting this.
    Anybody have any ideas ?

  2. #2
    Join Date
    Dec 2012
    Location
    California
    Posts
    336

    Default

    Have you tried reinstalling your Runtime Libraries?

    My Livestream @ Twitch.tv --> http://www.twitch.tv/asherao
    My YouTube Channel --> http://www.youtube.com/user/asheras

  3. #3
    Jason Whited's Avatar
    Jason Whited is offline Senior Community Leader
    Join Date
    Nov 2016
    Location
    Soutwest Virginia, USA
    Posts
    1,451

    Default

    Do you know how to take a screenshot and post it here?

    Or, if not, could you go into your graphics settings, make a list of them, and copy it here?
    Let's start simply and work from there.

    Also, a list of your audio settings, and your force feed back settings.

    Why?
    Because I'm relatively sure this is your problem.

    ...proof that AMS devs are aware of this issue being a memory allocation issue (use a translator if necessary. It's in Portuguese)
    Last edited by Jason Whited; 02-22-2018 at 07:30 AM.

  4. #4
    Gilles Lalonde's Avatar
    Gilles Lalonde is offline Senior Member
    Join Date
    Dec 2016
    Location
    Montreal, Quebec
    Posts
    465

    Default

    Hey Bob,

    So you have a new installation of Win10. But I don't know if it's the 32 or 64 bits version.

    First Bob, have you updated your graphic driver ?
    Did the tech who installed your Win10 say that he installed the real drivers for your graphic card?
    If he did not, you might be running Microsoft generic drivers.

    You have to run Speccy, save the snapshot and send it to me. It will tell me all of that.
    When you do run it, restart your computer just before, wait a few minutes for Win10 to finish all its start task and then run it.

    RFactor and Automobilista runtime error are "usually" due to the game running out of memory.

    When you practice OFF line, do you get the error?
    How many AI cars do you run when you practice?
    When you practice ON line alone or with a few other guys, do you get the error?
    We were just 20 at the last race, might be just that.

    rFactor and Automobilista are DirectX9 games and Win10 does not install DX9 by default.
    Since I always remove unneeded stuff like Support and Redistribution folders so I do not recollect what was inside theses folders.
    The very first folder of your AMS installation is "_CommonRedist", there should be an installer for DX9. I would run that first.
    Even if, on Automobilista installation, the Steam installer probably did install DX9, it won't do any harm
    Microsoft.com DirectX End-User Runtimes (June 2010)

    Since it is a new install, there's a big possibility that most RunTime libraries are not installed.
    C++ redist come in 32 and 64 bits and the version that usually works for rFactor is 2008. For Automobilista, I haven't found any info.

    Can somebody confirm if there is a C++ redistribution in the first folder?

    Microsoft.com Visual C++ 2008 Redist. 32 bits (x86)

    Microsoft.com Visual C++ 2008 Redist. 64 bits (x64)

    Bon courage!

    @Jason, nice page on 4GB of Memory usage in 32-bit Windows Process. I never was able to use the /3GB or the /PAE flags. It would often BSODed.
    For Win 10, it's a bcdedit command... LoL!
    No need for the 3GB flag in Win10: bcdedit /set IncreaseUserVa 3008
    Last edited by Gilles Lalonde; 02-22-2018 at 12:12 PM.
    I own crappy boxes... well you know what? 20gigs on a Asus P7P55 LX with an i7-860 running a used GTX970 4GD5T OC on an new AOC Q2963 screen... I'm doing way better! I even got myself a barely used G29! But I still endlessly mod rFactor...

  5. #5
    oldnslo's Avatar
    oldnslo is offline Bob Roberson
    Join Date
    Jun 2010
    Location
    Peachtree, NC
    Posts
    223

    Default

    OK, first of all. Thank you guys for your willingness to help. However, I'm having a lot of things happening in my life right now so if I don't respond right away I hope you understand. If I get fired up I'll try your suggestions. And, if all else fails I'll call you and let you walk me through it if it's not at a busy time for you. I thought at this time in my life I would be sitting on the porch drinking coffee and watching the wildlife. Boy was I ever wrong.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •